pip安装tensorflow遇到的一些问题

Could not find a version that satisfies the requirement tensorflow


使用pythonpip安装tensorflow提示:

Could not find a version that satisfies the requirement tensorflow

后来发现,tensorflow只支持64位的python

换成最新的64位python后,发现还提示这个错误。

又发现tensorflow只支持64位的python 3.6

最新的64位python 3.8还不支持。。。

Could not find a version that satisfies the requirement cv2


直接执行安装命令:

pip install cv2

提示:

Could not find a version that satisfies the requirement cv2

原来cv2根本不是一个python软件的包名,cv2只是opencv-python这个python软件包的一个组成部分。

换成:

pip install opencv-python

就好了

参考: